Print Topic - Archive

XBLite Forum  /  XBLite Programming  /  static lib
Posted by: ly47, September 20, 2016, 9:44pm
Hi
when compiling with static libs : IMPORT "xst_s.lib" IMPORT "xsx_s.lib" (benchmark.x)
Lots of errors.
But when changed to IMPORT "xst" IMPORT "xsx",  compiles fine.
I tried other examples that use static libs ,all the same errors.
Please help
thaks
ly
Posted by: XBLiteAdmin, November 15, 2016, 12:35am; Reply: 1
It sounds like you need to make sure all of the xblite environment variables are set correctly.
This will ensure the compiler can find all the required files needed to link to libraries, either static or dynamic ones.
See example below:

Name                           Value
----                           -----
INCLUDE                     G:\xblite\include;G:\xblite\include;include
LIB                            G:\xblite\lib;G:\xblite\lib;lib
M4PATH                      G:\xblite\include;G:\xblite\include;include
XBLDIR                       G:\xblite

To check if the environment variables are correctly set, you can open a Command Prompt console and type SET, or
in Windows 10, from Run, enter Powershell, then type Get-ChildItem Env:

In Windows, to manually change/edit the environment variables, Open Control Panel > System & Security > System > Advanced System Settings and in the System Properties Dialog under Advanced tab, click on Environment Variables. From there you can see the current variables for xblite, which are INCLUDE, LIB, PATH, M4PATH, and XBLDIR.
Print page generated: November 24, 2017, 1:49am