Print Topic - Archive

XBLite Forum  /  XBLite Installation Questions  /  Installing on Windows 7
Posted by: Geof, November 15, 2010, 1:07pm
I have installed xblite on windows 7 but when I try to compile a program I get a "fatal error - include not found:bad install".  :'(
Any ideas please?
Posted by: XBLiteAdmin, November 15, 2010, 7:17pm; Reply: 1
1. Did you run the install.exe program found in \xblite\bin\ folder?

2. Have you tried to run any of the demo *.bat programs, such as \xblite\demo\console\api\api.bat?
Posted by: Geof, November 15, 2010, 8:00pm; Reply: 2
Quoted from XBLiteAdmin
1. Did you run the install.exe program found in \xblite\bin\ folder?

2. Have you tried to run any of the demo *.bat programs, such as \xblite\demo\console\api\api.bat?


1. I did run the install.exe program and it reported that it had added the directories to the register.

2. I do not seem to have a demo folder, just a bin folder and tools folder.

Thank you. Geof.
Posted by: Guy1954, November 16, 2010, 1:18am; Reply: 3
Hi Geof,

Here is how I've installed XBLite under Windows 7.
I have 2 partitions:
- C: for my OS (Windows 7)
- D: for my data (including XBLite)

1. I downloaded xblite_241.zip
2. I unziped it in D: (getting the demo folder D:\xblite\demo)
3. I ran D:\xblite\bin\install.exe to update Windows registry
4. I created a shortcut to  D:\xblite\bin\xsed.exe

I'm suspecting that you retrieved an incomplete xblite_241.zip, since you are missing the demo folder.

What about starting from fresh and following my setup procedure?

Bye! Guy
Posted by: Guy1954, September 15, 2015, 9:06am; Reply: 4
Hi Geof,

Since I had some trouble with viXen's installation program that pointed to my drive D:,
I re-installed the entire xblite workbench on drive C:.

I reverted xblite's installation to C: because I was experiencing troubles with no sound reasons:
viXen's install procedure at SourceForge was pointing to D:!

If you are using another drive than C:, I suggest you also revert you installation to the C drive.

Don't forget to run again C:\xblite\bin\install.exe to update Windows registry, so that the environment variables point to C:.

Sorry for hinting you that D: was a good idea to host xblite, but I do use my mistakes to learn a little bit more.

Bye! Guy
Print page generated: November 24, 2017, 1:46am